Description


The following are common errors that you could encounter when setting up Catch Phish outlook add-in with MPaware and should serve as a guide to assist in resolving the issue. 


The Process


Errors that can occur:

1. Infinite Loading

Possible Cause: 

An issue has been identified with the Catch Phish Email Plug-in loading for some users. The cause of this issue has been linked to an update made by Microsoft which turns off all legacy Exchange user identity and callback tokens by default for Exchange Online tenants, encouraging the adoption of Nested App Authentication (NAA). This change affects Outlook add-ins that rely on these tokens, potentially impacting their functionality.

Solution:

You will need to re-deploy the Catch Phish plugin.

After re-deploying the plug-in and verifying the old plugin has been removed as well, you will need to wait between 12-24 hours for Outlook to process the change. 


2. Eligibility Requirements Error

Possible Cause: 

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If you get the Eligibility Requirements error when deploying Catch Phish, it is most likely a role and permission issue assigned to your Global Administrator account. 

Solution:

Follow the steps below to ensure you have the correct role and permission.

  • In Exchange Admin, navigate to Roles > Admin Roles > Organization Management
  • Click on the Assigned tab and make sure the Organization Management role is assigned to the Global Administrator account

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  • Click on the Permissions tab and make sure Org Marketplace Apps is enabled

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3. Blank Screen

Possible Cause: 

Most likely something is preventing access to catchphish.email. It can be local firewall software, VPN software, proxy configuration or Metered Connection setting.

Solution:

Refresh the add-in by right clicking in the blank area, and select “Reload”/”Refresh”. You may need to also remove and re-deploy the add-in to check this issue found here. Try switching to another network connection and try again. Check to make sure catchphish.email is not being blocked by any firewall software. Below are some methods to check if the Catch Phish domain is being blocked. Check all these steps to make sure they all pass if not then catchphish.email needs to be whitelisted.

Through Windows command prompt using NSLOOKUP:

  • Open a windows command prompt
  • Run the command “nslookup catchphish.email”
  • The results should look like this

 

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Through the web browser:

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4. Error:

"Sorry, we can't load the add-in. Please make sure you have network and/or Internet connectivity. Click "Retry" once you're back online.
Sorry, you seem to have lost your network and/or Internet connection. Click "Retry" once you're back online."


Possible Cause: 

Most likely something is preventing access to catchphish.email. It can be local firewall software, VPN software, proxy configuration or Metered Connection setting.

Solution:

Try switching to another network connection and try again. Check to make sure catchphish.email is not being blocked by any firewall software. 



5. Error:

"This app could not be started. Close this dialog to ignore the problem or click "Restart" to try again. "


Possible Cause: 

O365 version may be outdated 

Solution:

Verify that the latest Office updates are installed or update accordingly


6. Error:

 Sorry, we couldn't load the add-in because your version of Internet Explorer is not supported.
Click “See Details” for a list of supported browser versions. 


Possible Cause: 

Outlook needs Internet Explorer to run Catchphish add-in but the version you have installed may be too old.

Solution:

Update your IE to a newer version, or upgrade your Windows and/or Office so Catchphish add-in can be run in Microsoft Edge or Chromium Edge.

 

7. Error:

Sorry, we couldn't load the add-in because your browser version is not supported.
Click here for a list of supported browser versions.

Possible Cause: 

Internet Explorer is not installed or it has been disabled.

Solution:

Re-install / re-activate Internet Explorer.

  1. Right Click the Start icon and select Control Panel

  2. Click Programs

  3. Choose Programs and Features

  4. Click Turn Windows features on or off

  5. Check the box next to Internet Explorer 11

  6. Reboot Windows in order to finalize the changes and re-enable Internet Explorer.


8. Error:

Sorry, we couldn't load the add-in because Internet Explorer is disabled.
Click “See Details” for more information.

Possible Cause: 

Internet Explorer settings (in Internet Options) are corrupt.

Solution:

Reset Internet Explorer settings.

  1. Open Internet Options (press Windows key + R, type inetcpl.cpl and press Enter key).
  2. Select the Advanced tab.
  3. In the Reset Internet Explorer Settings dialog box, select Reset.

  4. In the box, Are you sure you want to reset all Internet Explorer settings?, select Reset.

  5. When Internet Explorer finishes applying default settings, select Close, and then select OK. Restart your PC to apply changes.


9. Error:

A problem occurred while trying to reach this add-in.

Possible Cause: 

There might be a problem accessing the plugin. Issue may be temporary (downtime on Microsoft side) or more permanent (proxy, firewall, Enterprise Mode etc. is blocking access).

Solution:

Please switch to another network connection and try again. Make sure proxy or firewall is not blocking access to catchphish.email.


Enable Protected Mode in Internet Options > Security > Trusted sites.


Add *catchphish.email to the Sites list. Reboot and check if problem is fixed